让Emacs支持php高亮

2012-07-31 9:38 by Elliot

想要学习php, 就从wordpress的源码下手吧, 可是我用emacs打开一个php文件后才发现原来我的emacs默认没有php-mode, 在sourceforge上找到了http://sourceforge.net/projects/php-mode/, 下载后将php-mode.el放在.emacs-lisp文件夹下(.emacs-lisp是我自己建立的在home文件夹下专门用来存放从网上下载的emacs文件的~/.emacs-lisp), 修改.emacs文件, 在后面增加

;;php-mode
(add-to-list 'load-path "~/.emacs-lisp")
(require 'php-mode)
(add-hook 'php-mode-user-hook 'turn-on-font-lock)

OK, 大功告成.

本文基于 署名 2.5 中国大陆 许可协议发布,欢迎转载,演绎或用于商业目的,但是必须保留本文的署名 Elliot 并包含 原文链接
本文暂时还没有评论,你可以抢沙发哟。

发表评论